3

Avoid the Frustration: How to Disable AutoCorrect in OS X

Posted by Jim Tanous on September 18, 2015
os x autocorrect

Intended to be a typo-killing tool that would elevate all of our online discourse to new heights of grammatical correctness, the AutoCorrect feature found in iOS and OS X frequently does more harm than good. While often providing examples of hilarity, just about everyone has been driven to madness by the feature at one point or another, forced to type and retype certain words — especially abbreviations or specialized words not found in the dictionary — over and over again as our Apple devices insist on correcting us.
Here’s an example, which happens to be the impetus for this impromptu tip: I enjoy reading PC Perspective, the PC hardware news and reviews website. PC Perspective‘s domain is pcper.com (either because pcperspective.com was unavailable when the site launched about 10 years ago, or because founder and editor-in-chief Ryan Shrout wanted to keep things short and sweet). But when I went to visit PC Perspective this evening, OS X insisted on changing “pcper” to “paper.” Every. DarnTime.

os x autocorrect safari

That’s not what I typed, OS X!


Now there are ways to get around this example of AutoCorrect abuse — I could add “pcper” to the OS X Dictionary, and AutoCorrect generally leaves sites that are in your Safari Bookmarks, or recently visited, alone — but I was working with a fresh install of OS X El Capitan, hadn’t added my bookmarks yet, and didn’t want to add a fake word to the system dictionary just to avoid Apple’s asinine implementation of AutoCorrect (I mean, seriously, it’s one thing for AutoCorrect to change the word once, but when the user goes back and edits it once, twice, and even three times, AutoCorrect should take the freaking hint).
I also knew that PC Perspective was just one example, and that making an exception for it — by adding it to the Dictionary, for example — wouldn’t do anything to avoid the countless future examples of frustrating clashes with AutoCorrect. So I decided to turn AutoCorrect off on my Mac, and oh, how sweet it is. Here’s how you can disable AutoCorrect in OS X, too.
To disable AutoCorrect, head to System Preferences > Keyboard > Text. There, find the option labeled “Correct spelling automatically” and uncheck it.
os x disable autocorrect
That’s it; there are no other settings to adjust and you don’t need to reboot or log off. As soon as that box is unchecked, OS X will stop trying to automatically correct your words. You’ll still get the useful spellcheck features — so poor typists and spelling bee dropouts need not worry — OS X simply won’t automatically change your words anymore, and you’ll hopefully avoid some frustrating and embarrassing moments in the future.
os x safari pc perspective

Ah…that’s better!


It’s important to note, however, that this option only applies to the system-wide AutoCorrect feature found in default Apple apps and third party apps that use Apple’s APIs. Some third party apps, like Microsoft Word, have their own internal AutoCorrect features, so you’ll need to configure those manually as needed.
microsoft word for mac autocorrect

Apps like Microsoft Word have their own AutoCorrect features and settings


If you ever find yourself missing AutoCorrect in OS X and want to turn it back on, just head back to System Preferences > Keyboard > Text and check the “Correct spelling automatically” box. Just as when you disabled it, the feature will be enabled as soon as the box is checked.

3 thoughts on “Avoid the Frustration: How to Disable AutoCorrect in OS X”

Grey Randall says:
This does not work. As Pontius Pilate says.
It’s becoming a HUGE hassle when you are trying to search on a proper title, and Safari keeps changing it, so you can’t search
Reply
Pontius Pilate says:
Bullshit! I’m running the latest Safari in Seirra and even with the GD auto-corrct off it STILL FUCKING KEEPS on.
Reply
Zoe Butcher says:
Thank you so much for this article. I was pulling my hair out trying to figure out how to shut the broken auto correct feature off. The problem is I couldn’t figure out if it was Google, Safari, or OSX. <3
Reply

Leave a Reply

Your email address will not be published. Required fields are marked *


Disclaimer: Some pages on this site may include an affiliate link. This does not effect our editorial in any way.